lkml.org 
[lkml]   [2012]   [Jan]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v5 1/3] seccomp: kill the seccomp_t typedef
From
Date
On Fri, 2012-01-27 at 17:47 -0600, Will Drewry wrote:
> On Fri, Jan 27, 2012 at 5:41 PM, Greg KH <gregkh@suse.de> wrote:
> > On Fri, Jan 27, 2012 at 05:24:39PM -0600, Will Drewry wrote:
> >> Replaces the seccomp_t typedef with seccomp_struct to match modern
> >> kernel style.
> >>
> >> Signed-off-by: Will Drewry <wad@chromium.org>
> >> ---
> >> include/linux/sched.h | 2 +-
> >> include/linux/seccomp.h | 10 ++++++----
> >> 2 files changed, 7 insertions(+), 5 deletions(-)
> >>
> >> diff --git a/include/linux/sched.h b/include/linux/sched.h
> >> index 4032ec1..288b5cb 100644
> >> --- a/include/linux/sched.h
> >> +++ b/include/linux/sched.h
> >> @@ -1418,7 +1418,7 @@ struct task_struct {
> >> uid_t loginuid;
> >> unsigned int sessionid;
> >> #endif
> >> - seccomp_t seccomp;
> >> + struct seccomp_struct seccomp;
> >
> > Isn't 'struct seccomp_struct' a bit redundant?
> >
> > How about a simple 'struct seccomp' instead?
>
> Works for me - I can't recall why that seemed to make sense (other
> than the user of similar redundant names elsewhere).

seccomp_struct for a type is okay, but you also have:

+#define seccomp_struct_init_task(_seccomp) do { } while (0);
+#define seccomp_struct_fork(_tsk, _orig) do { } while (0);
+#define seccomp_struct_free_task(_seccomp) do { } while (0);

in patch 2/3, "struct" in these function/macro names is redundant.

Thanks.




\
 
 \ /
  Last update: 2012-01-28 12:19    [W:0.290 / U:0.516 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site