lkml.org 
[lkml]   [2012]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5] memcg: remove PCG_CACHE page_cgroup flag
On Wed, Jan 25, 2012 at 02:41:00PM +0900, KAMEZAWA Hiroyuki wrote:
> Subject: [PATCH v5] memcg: remove PCG_CACHE
>
> We record 'the page is cache' by PCG_CACHE bit to page_cgroup.
> Here, "CACHE" means anonymous user pages (and SwapCache). This
> doesn't include shmem.
>
> Consdering callers, at charge/uncharge, the caller should know
> what the page is and we don't need to record it by using 1bit
> per page.
>
> This patch removes PCG_CACHE bit and make callers of
> mem_cgroup_charge_statistics() to specify what the page is.
>
> About page migration:
> Mapping of the used page is not touched during migration (see
> page_remove_rmap) so we can rely on it and push the correct charge type
> down to __mem_cgroup_uncharge_common from end_migration for unused page.
> The force flag was misleading was abused for skipping the needless
> page_mapped() / PageCgroupMigration() check, as we know the unused page
> is no longer mapped and cleared the migration flag just a few lines
> up. But doing the checks is no biggie and it's not worth adding another
> flag just to skip them.
>
> Changelog since v4
> - fixed a bug at page migration by Michal Hokko.
>
> Changelog since v3
> - renamed a variable 'rss' to 'anon'
>
> Changelog since v2
> - removed 'not_rss', added 'anon'
> - changed a meaning of arguments to mem_cgroup_charge_statisitcs()
> - removed a patch to mem_cgroup_uncharge_cache
> - simplified comment.
>
> Changelog since RFC.
> - rebased onto memcg-devel
> - rename 'file' to 'not_rss'
> - some cleanup and added comment.
>
> Signed-off-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>

Acked-by: Johannes Weiner <hannes@cmpxchg.org>


\
 
 \ /
  Last update: 2012-01-25 14:39    [W:0.044 / U:1.432 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site