lkml.org 
[lkml]   [2012]   [Jan]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Bug 41722] Clevo M5X0JE hangs in ACPI init
On Thu, Jan 19, 2012 at 11:48:29AM -0800, Yinghai Lu wrote:
> 2012/1/19 Rogério Brito <rbrito@ime.usp.br>:
> >
> > OK, now it seems that we are getting farther. The system boots, even
> > mounts the root filesystem, udev starts and, then, when it seems that
> > some USB messages are going to appear on the screen, the notebook
> > crashes with the same distortion that happened before (with some of
> > the last messages appearing being related to OHCI).
>
> in that case, Can you try to disable OHCI in .config
>
> CONFIG_USB_OHCI_HCD
>
> OHCI controller 00:0b.0 is using
> Memory at b0004000 (32-bit, non-prefetchable) [size=4K]
>
> VGA controller 00:05.0
> Memory at b2000000 (32-bit, non-prefetchable) [size=16M]
> Memory at c0000000 (64-bit, prefetchable) [size=256M]
> Memory at b1000000 (64-bit, non-prefetchable) [size=16M]
> [virtual] Expansion ROM at 80000000 [disabled] [size=128K]
>
> it seems not related. or could be ioremap etc have problem?
>
> So can you try to boot with nopat?

Yinghai/Bjorn,

After carefully examination of the allocations done by the vanilla upstream
kernel; the one without the 'skip transparent bridge while sizing' code,
I find that the allocation to one of the Bar; BAR[16], of the CardBus Bridge at 05:07.0
does not overlap that of the parent transparent bridge at 00:10.0

Here is what I see in the video at
http://www.youtube.com/watch?v=_dYhkWHfep0&feature=youtu.be

[268.002554] pci 0000:05:07.0: Cardbus bridge to [bus 06-09]
[269.002582] pci 0000:05:07.0: bridge window [io 0x1400-0x14ff]
[270.009090] pci 0000:05:07.0: bridge window [io 0x1000-0x10ff]
[271.012358] pci 0000:05:07.0: bridge window [mem 0x84000000-0x87ffffff pref]
[272.015626] pci 0000:05:07.0: bridge window [mem 0x88000000-0x8bffffff]
^^^^^^^^^^^^^^^^^^^^^^^^^^^^ offending allocation
[273.018894] pci 0000:00:10.0: PCI bridge to [bus 05-06]
[274.022162] pci 0000:00:10.0: bridge window [io 0x1000-0x1fff]
[275.025430] pci 0000:00:10.0: bridge window [mem 0xb3200000-0xb32fffff]
[276.028698] pci 0000:00:10.0: bridge window [mem 0xb8400000-0x87ffffff pref]

To me, the issue seems to be that due to some reason the OS either fails to Or does not try to
reallocate the addresses assigned to the the non-pref mem BAR of the the transparent bridge
at 00:10.0.

In any case since you have deeper knowledge in this area, I will let you verify my theory.
RP

>
> Thanks
>
> Yinghai

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2012-01-21 10:29    [from the cache]
©2003-2011 Jasper Spaans