lkml.org 
[lkml]   [2012]   [Jan]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v3] memcg: remove PCG_CACHE page_cgroup flag
On Fri, Jan 20, 2012 at 12:26:58PM +0900, KAMEZAWA Hiroyuki wrote:
> I think this version is much simplified.
>
> ==
> >From 5700a4fe9c581e1ebaa021ba6119dc8d921b024f Mon Sep 17 00:00:00 2001
> From: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>
> Date: Thu, 19 Jan 2012 17:09:41 +0900
> Subject: [PATCH v3] memcg: remove PCG_CACHE
>
> We record 'the page is cache' by PCG_CACHE bit to page_cgroup.
> Here, "CACHE" means anonymous user pages (and SwapCache). This
> doesn't include shmem.
>
> Consdering callers, at charge/uncharge, the caller should know
> what the page is and we don't need to record it by using 1bit
> per page.
>
> This patch removes PCG_CACHE bit and make callers of
> mem_cgroup_charge_statistics() to specify what the page is.
>
> Changelog since v2
> - removed 'not_rss', added 'anon'
> - changed a meaning of arguments to mem_cgroup_charge_statisitcs()
> - removed a patch to mem_cgroup_uncharge_cache
> - simplified comment.
>
> Changelog since RFC.
> - rebased onto memcg-devel
> - rename 'file' to 'not_rss'
> - some cleanup and added comment.
>
> Signed-off-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>

Apart from Michal's rss -> anon renaming suggestion, which I agree
with:

Acked-by: Johannes Weiner <hannes@cmpxchg.org>


\
 
 \ /
  Last update: 2012-01-20 11:37    [from the cache]
©2003-2011 Jasper Spaans