lkml.org 
[lkml]   [2012]   [Jan]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: radeon issues on MacBook Pro 8,2
From
On Fri, Jan 20, 2012 at 10:53 AM, Seth Forshee
<seth.forshee@canonical.com> wrote:
> On Thu, Jan 19, 2012 at 02:53:17PM -0600, Seth Forshee wrote:
>> > >  2. Occasional long delays when suspending. When this happens I see
>> > >    messages like following in dmesg:
>> > >
>> > >      [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
>> > >      [drm:atom_execute_table_locked] *ERROR* atombios stuck executing D44E (len 62, WS 0, PS 0) @ 0xD46A
>> > >
>> > >    Sometimes one of suspend or resume hangs completely, but I can't
>> > >    tell which and am not sure whether or not it's related. I'm also
>> > >    testing a Mac Mini with the exact same card which does not seem to
>> > >    suffer from this issue.
>> > >
>> > >    I ran a bisections that identified f8d0edd (drm/radeon/kms: improve
>> > >    DP detect logic) as introducing problems with suspend, and reverting
>> > >    this patch on top of 3.2.1 does seem to eliminate both issues.
>> > >
>> >
>> > That patch doesn't really affect the modesetting paths directly; it
>> > looks like a red herring to me.
>>
>> Perhaps. I just started a run of 200 s3 cycles with the patch reverted
>> to see if I can reproduce the issues. I can usually trigger the problem
>> with 15 or fewer s3 cycles.
>
> The machine completed 200 s3 cycles with the patch reverted without long
> delays, hangs, or any atombios error messages. Without reverting it
> doesn't get through many at all before experiencing the errors and long
> delays or hangs.
>
> I added a printout of the connector status resulting from the logic that
> was changed by f8d0edd. With the logic prior to this commit it
> consistently returns the status as disconnected, which is correct as I
> have nothing connected. But with the improved logic the status is
> sometimes reported as connected, and these coincide with the atombios
> errors.
>

Do any of the disconnected displayport connectors get misdetected as
connected during normal operation or does it only happen during
suspend/resume?

Alex
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2012-01-20 20:41    [W:0.124 / U:0.500 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site