[lkml]   [2011]   [Sep]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC][PATCH 0/5] Introduce checks for preemptable code for this_cpu_read/write()
On Wed, 21 Sep 2011, Steven Rostedt wrote:

> The problem I have with this, is that this does not help at all. We are
> back to the word "this_cpu" when you really do mean "any_cpu". We

We mean the current cpu while the instruction is executing.

> Again, lets just bite the bullet and rename them to something that is
> understandable for everyone. This would make all of us happy.
> I'm not against your code, I'm against the naming convention you decided
> to use. It makes it confusing to something that is complex and complex
> code needs to try to be a simple as possible.

I am certainly open to new ways of structuring the stuff and for any
improvement possible. This whole scheme was developed in long discussions
over many years. My initial proposal was to use cpu_inc/dec etc. I did
what was possible in the context of the various opinions that people had
on these matters when the implementations were discussed. The "you" does
not apply. It is either "us" or "them" (if you want to distance yourself
from this).

 \ /
  Last update: 2011-09-21 18:01    [W:0.076 / U:10.816 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site