Messages in this thread |  | | Date | Sun, 11 Sep 2011 10:12:34 -0400 | | From | Christoph Hellwig <> | | Subject | Re: Kernel 3.1.0-rc4 oops when connecting iPod |
| |
On Sat, Sep 10, 2011 at 11:52:55PM -0400, Pavel Ivanov wrote: > > Agreed. It was more of a quick hack to prove the correctness of such > > change direction. I'll think how to do it better. > > Hin-Tak, > > How about the following patch? > > > Subject: [PATCH] hfsplus: Allow to mount filesystem with block size > greater than PAGE_SIZE > > Commit c6d5f5fa (hfsplus: lift the 2TB size limit) added call to > generic_check_addressable() but used the system's internal block size > which can be larger than PAGE_SIZE and will cause > generic_check_addressable() to return -EINVAL in this case. This > results in impossibility to mount file systems with such block sizes. > To fix it we have to use block size understandable by > generic_check_addressable() and adjust number of blocks accordingly.
Given that a large part of the checks are related to the actual block size I think that we're better off just opencoding it.
|  |