lkml.org 
[lkml]   [2011]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH 1/2] staging: et131x: Fix checkpatch whitespace warnings
From
Date
On Sat, 2011-09-03 at 12:49 +0100, Mark Einon wrote:
> Some of my previous hacking attempts have not been following the rules.
> All fixes either lines > 80 chars or whitespace corrections (spaces->tabs etc).
[]
> diff --git a/drivers/staging/et131x/et1310_mac.c b/drivers/staging/et131x/et1310_mac.c
> index ab85cb3..36f2168 100644
> --- a/drivers/staging/et131x/et1310_mac.c
> +++ b/drivers/staging/et131x/et1310_mac.c
> @@ -191,7 +191,8 @@ void et1310_config_mac_regs2(struct et131x_adapter *adapter)
> cfg1 |= CFG1_RX_ENABLE | CFG1_TX_ENABLE | CFG1_TX_FLOW;
> /* Initialize loop back to off */
> cfg1 &= ~(CFG1_LOOPBACK | CFG1_RX_FLOW);
> - if (adapter->flowcontrol == FLOW_RXONLY || adapter->flowcontrol == FLOW_BOTH)
> + if (adapter->flowcontrol == FLOW_RXONLY ||
> + adapter->flowcontrol == FLOW_BOTH)

Especially in cases like this, it helps readability
to align to open parenthesis like:

if (adapter->flowcontrol == FLOW_RXONLY ||
adapter->flowcontrol == FLOW_BOTH)

[]
> @@ -641,7 +641,8 @@ static inline void free_send_packet(struct et131x_adapter *adapter,
> * they point to
> */
> do {
> - desc = (struct tx_desc *)(adapter->tx_ring.tx_desc_ring +
> + desc = (struct tx_desc *)
> + (adapter->tx_ring.tx_desc_ring +
> INDEX10(tcb->index_start));

Isn't this an unnecessary cast?
Perhaps it's better as:

u32 i10 = INDEX10(tcb->index_start);

desc = &adapter->tx_ring.tx_desc_ring[i10];



\
 
 \ /
  Last update: 2011-09-10 07:43    [W:0.061 / U:0.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site