lkml.org 
[lkml]   [2011]   [Aug]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH][Resend] Remove unneeded version.h includes (and add where needed) for drivers/usb/
Date
Hi Felipe,

On Wednesday 03 August 2011 00:50:42 Felipe Balbi wrote:
> On Wed, Aug 03, 2011 at 12:11:53AM +0200, Laurent Pinchart wrote:
> > On Tuesday 02 August 2011 23:19:24 Felipe Balbi wrote:
> > > On Mon, Aug 01, 2011 at 11:33:29PM +0200, Jesper Juhl wrote:
> > > > It was pointed out by 'make versioncheck' that linux/version.h was
> > > > not always being included where needed and sometimes included
> > > > needlessly in drivers/usb/.
> > > > This patch fixes up the includes.
> > > >
> > > > For the UVC gadget driver bits, this was ACK'ed by Laurent Pinchart.
> > > >
> > > > Signed-off-by: Jesper Juhl <jj@chaosbits.net>
> > > > Acked-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> > > > ---
> > > >
> > > > drivers/usb/gadget/uvc.h | 1 +
> > > > drivers/usb/gadget/uvc_v4l2.c | 1 -
> > > > drivers/usb/storage/realtek_cr.c | 1 -
> > > > 3 files changed, 1 insertions(+), 2 deletions(-)
> > > >
> > > > diff --git a/drivers/usb/gadget/uvc.h b/drivers/usb/gadget/uvc.h
> > > > index 5b79194..81971fb 100644
> > > > --- a/drivers/usb/gadget/uvc.h
> > > > +++ b/drivers/usb/gadget/uvc.h
> > > > @@ -56,6 +56,7 @@ struct uvc_event
> > > >
> > > > #include <linux/usb.h> /* For usb_endpoint_* */
> > > > #include <linux/usb/gadget.h>
> > > > #include <linux/videodev2.h>
> > > >
> > > > +#include <linux/version.h>
> > >
> > > does uvc.h really needs <linux/version.h> ?? Laurent ?
> >
> > uvc.h has
> >
> > #define DRIVER_VERSION_NUMBER KERNEL_VERSION(0, 1, 0)
> >
> > This is used in drivers/usb/gadget/uvc_v4l2.c only.
> >
> > As the uvc gadget driver lives in-tree, the best fix is probably to
> > remove DRIVER_VERSION_NUMBER completely, and replace it with
> > LINUX_VERSION_CODE where it is used.
>
> yeah, I can agree with that, but do you need a MODULE_VERSION() anyway ?
> Would it be better to just remove the MODULE_VERSION altogether as
> there's no real benefit from having it ?

DRIVER_VERSION_NUMBER isn't used as a MODULE_VERSION() argument. The driver
uses it to report its version through the V4L2 API.

--
Regards,

Laurent Pinchart


\
 
 \ /
  Last update: 2011-08-03 10:21    [from the cache]
©2003-2011 Jasper Spaans