lkml.org 
[lkml]   [2011]   [Aug]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 04/13] mm: new shrinker API
On Tue, Aug 23, 2011 at 07:23:30PM +1000, Dave Chinner wrote:
> > It's much more than just a single callback these days.
> >
> > > + * @scan_objects will be made from the current reclaim context.
> > > */
> > > struct shrinker {
> > > int (*shrink)(struct shrinker *, struct shrink_control *sc);
> > > + long (*count_objects)(struct shrinker *, struct shrink_control *sc);
> > > + long (*scan_objects)(struct shrinker *, struct shrink_control *sc);
> >
> > Is shrink_object really such a good name for this method?
>
> Apart from the fact it is called "scan_objects", I'm open to more
> appropriate names. I called is "scan_objects" because of the fact we
> are asking to scan (rather than free) a specific number objects on
> the LRU, and it matches with the "sc->nr_to_scan" control field.

Shrink_objects actually was my suggestion - while we are asked to scan
the objects the scan really isn't the main purpose of it.



\
 
 \ /
  Last update: 2011-08-24 08:19    [W:0.704 / U:0.244 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site