lkml.org 
[lkml]   [2011]   [Aug]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: [PATCH 1/3] [SCSI] sd: consolidate sector size alignment check in sd_pref_fn
From
Date
On Tue, 2011-08-02 at 12:50 +0900, Namhyung Kim wrote:
> Generalize common code to reduce code duplication.

This code isn't equivalent because it won't fail sector sizes > 4096
which we can't support.

Plus I really don't see much point doing this: ilog2 is a far less
efficient operation on several platforms and this is the hot path.

James

> Signed-off-by: Namhyung Kim <namhyung@gmail.com>
> ---
> drivers/scsi/sd.c | 32 ++++++++------------------------
> 1 files changed, 8 insertions(+), 24 deletions(-)
>
> diff --git a/drivers/scsi/sd.c b/drivers/scsi/sd.c
> index 953773cb26d9..463a324835f4 100644
> --- a/drivers/scsi/sd.c
> +++ b/drivers/scsi/sd.c
> @@ -735,36 +735,20 @@ static int sd_prep_fn(struct request_queue *q, struct request *rq)
> * and not force the scsi disk driver to use bounce buffers
> * for this.
> */
> - if (sdp->sector_size == 1024) {
> - if ((block & 1) || (blk_rq_sectors(rq) & 1)) {
> - scmd_printk(KERN_ERR, SCpnt,
> - "Bad block number requested\n");
> - goto out;
> - } else {
> - block = block >> 1;
> - this_count = this_count >> 1;
> - }
> - }
> - if (sdp->sector_size == 2048) {
> - if ((block & 3) || (blk_rq_sectors(rq) & 3)) {
> - scmd_printk(KERN_ERR, SCpnt,
> - "Bad block number requested\n");
> - goto out;
> - } else {
> - block = block >> 2;
> - this_count = this_count >> 2;
> - }
> - }
> - if (sdp->sector_size == 4096) {
> - if ((block & 7) || (blk_rq_sectors(rq) & 7)) {
> + if (sdp->sector_size > 512) {
> + int shift = ilog2(sdp->sector_size) - 9;
> +
> + if (!IS_ALIGNED(block, 1 << shift) ||
> + !IS_ALIGNED(blk_rq_sectors(rq), 1 << shift)) {
> scmd_printk(KERN_ERR, SCpnt,
> "Bad block number requested\n");
> goto out;
> } else {
> - block = block >> 3;
> - this_count = this_count >> 3;
> + block = block >> shift;
> + this_count = this_count >> shift;
> }
> }
> +
> if (rq_data_dir(rq) == WRITE) {
> if (!sdp->writeable) {
> goto out;




\
 
 \ /
  Last update: 2011-08-02 18:31    [W:0.392 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site