lkml.org 
[lkml]   [2011]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: of_iomap() matched with plan iounmap()
    On Fri, Aug 19, 2011 at 02:26:18PM +0200, Arnd Bergmann wrote:
    > On Friday 19 August 2011, David Miller wrote:
    > > From: David Brown <davidb@codeaurora.org>
    > > Date: Thu, 18 Aug 2011 10:02:26 -0700
    > >
    > > > The SPARC target contains of_ioremap() and of_iounmap(), which various
    > > > drivers use (generally inside of CONFIG_SBUS).
    > > >
    > > > include/linux/of_address.h contains a definition for of_iomap(), but
    > > > not corresponding unmap call. Code using this calls the regular
    > > > iounmap().
    > > >
    > > > Is it safe to assume that of_iomap() will always be based on ioremap()
    > > > and therefore it is safe to use iounmap(), or would it be better to
    > > > define another name for drivers to use as the inverse of of_iomap().
    > > > I'm not sure what to call it, since of_iounmap() is already taken by
    > > > SPARC.
    > >
    > > It's better to define a matching of_iounmap() interface, even if for
    > > now it is exactly iounmap()
    >
    > But the problem is that we need conflicting prototypes for of_iounmap.

    What if we left the SPARC calls alone, and changed of_iomap() into
    of_dt_iomap() and could then make of_dt_iounmap(). Or, it could just
    be of_dt_map(), and of_dt_unmap().

    David

    --
    Sent by an employee of the Qualcomm Innovation Center, Inc.
    The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.


    \
     
     \ /
      Last update: 2011-08-19 23:21    [W:0.023 / U:32.124 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site