[lkml]   [2011]   [Aug]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: of_iomap() matched with plan iounmap()
From: David Brown <>
Date: Thu, 18 Aug 2011 10:02:26 -0700

> The SPARC target contains of_ioremap() and of_iounmap(), which various
> drivers use (generally inside of CONFIG_SBUS).
> include/linux/of_address.h contains a definition for of_iomap(), but
> not corresponding unmap call. Code using this calls the regular
> iounmap().
> Is it safe to assume that of_iomap() will always be based on ioremap()
> and therefore it is safe to use iounmap(), or would it be better to
> define another name for drivers to use as the inverse of of_iomap().
> I'm not sure what to call it, since of_iounmap() is already taken by

It's better to define a matching of_iounmap() interface, even if for
now it is exactly iounmap()

 \ /
  Last update: 2011-08-19 05:41    [W:0.071 / U:2.772 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site