lkml.org 
[lkml]   [2011]   [Jul]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [arch-general] Panic - no sound devices after upgrade
On Thu, Jul 21, 2011 at 03:00:32PM +0200, Tom Gundersen wrote:
> Adrian, Takashi: I added you to cc, as you last touched this code,
> sorry if I should have cc'ed someone else. It appears that the HDSPM
> module does not recognise cards with firmware revision 0xCC:
>
> On Thu, Jul 21, 2011 at 1:23 PM, Fons Adriaensen <fons@linuxaudio.org> wrote:
> >>>>> * The driver for my card (RME HDSP MADI, snd_hdpsm) is loaded.
> >> > [   48.057757] HDSPM: unknown firmware revision cc
> [...]
> > Today I tried again downgrading the kernel to 2.6.37, to check if
> > the firmware revision error would occur. It doesn't.
> [...]
> > Tentative conclusion: the snd_hdspm driver in 2.6.39 is not OK.
>
> Ah, I see. Thanks for the clarification. This means that the kernel is
> not able to recognise your card. Pre-.39 it would load anyway, but
> since .39 it gives the warning you posted and refuses to load. Your
> firmware revision is 0xCC, which is not recognised. If your card is
> MADI, the kernel expects the firmware revision to be 0xD2 (or starting
> in 3.0, it also accepts 0xCF).
>
> I guess this can be fixed easily by adding your firmware revision to
> the list of accepted revs.

I have cards with CC and CF, and maybe also D2 (haven't checked them
all).

--
FA




--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2011-07-21 15:21    [W:0.099 / U:3.596 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site