lkml.org 
[lkml]   [2011]   [Jul]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 21/21] dynamic_debug: delete pending queries
From
Date
On Wed, 2011-07-20 at 11:43 -0600, Jim Cromie wrote:
> On Mon, Jul 11, 2011 at 6:25 PM, Joe Perches <joe@perches.com> wrote:
> > On Mon, 2011-07-11 at 01:46 -0600, Jim Cromie wrote:
> >> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> > []
> >> @@ -505,7 +505,17 @@ static int ddebug_save_pending(struct ddebug_query *query,
[]
> >> + if (verbose)
> >> + pr_info("delete pending: %s\n",
> >> + show_pending_query(pq));
> > I think these should be pr_debug.
> > I know you're only using the current style.
> > Jason, any reason these can not be converted?
> one other corner case (in addition to pr_cont, which I probly should
> have addressed to you)
> +#define pr_fmt(fmt) KBUILD_MODNAME ":%s: " fmt, __func__
> makes pr_debug unconditionally print stuff that can be
> doubled up if flags are also used.
> Ive done s/pr_info/pr_debug/ locally, when combined with:
> ddebug_query="module dynamic_debug +pfmlt "
> lines are too long, and are redundant
> This is pretty trivial, and can be avoided by
> "dont add those flags then", but I could imagine it
> being a minor annoyance wherever both pr_debug
> and pr_info|warn|err|etc are used together.
> Perhaps pr_debug and friends should ignore pr_fmt
> under CONFIG_DYNAMIC_DEBUG ?

Better I think would be to remove __func__ from those
dynamic debug pr_fmt defines.

Actually, I think it's better to never use __func__,
but that's an argument for a different day.

I think the only reason Jason did it was to always
have __func__ printed. If those become pr_debug
then anyone that really wants to can use +pf.

cheers, Joe



\
 
 \ /
  Last update: 2011-07-21 00:11    [W:0.100 / U:0.152 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site