lkml.org 
[lkml]   [2011]   [Jun]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5 9/9] x86-64: Add CONFIG_UNSAFE_VSYSCALLS to feature-removal-schedule

* pageexec@freemail.hu <pageexec@freemail.hu> wrote:

> On 6 Jun 2011 at 11:31, Andi Kleen wrote:
>
> > and assumes everyone is using glibc which is just wrong.
>
> the libc is irrelevant, they can all be fixed up to use the vdso
> entry points if they haven't been doing it already. already
> deployed systems will simply continue to use their flawed kernel
> and libc, they're not affected.

Correct, the libc is irrelevant here really - a distro will obviously
enable or disable CONFIG_COMPAT_VSYSCALL=y based on the type and
version of libc it is using.

This has been pointed out to Andi before.

Unfortunately Andi has been spouting nonsense in this thread without
replying to mails that challenge his points, such as:

http://marc.info/?l=linux-kernel&m=130686838202409
and: http://marc.info/?l=linux-kernel&m=130686827002311
and: http://marc.info/?l=linux-kernel&m=130687014804697

Thanks,

Ingo


\
 
 \ /
  Last update: 2011-06-06 16:55    [from the cache]
©2003-2011 Jasper Spaans