lkml.org 
[lkml]   [2011]   [Jun]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/2] bluetooth: Add bt_printk, convert logging macros to lower case
From
Date
On Thu, 2011-06-30 at 00:31 -0300, Gustavo F. Padovan wrote:
> Hi Joe,

Hello Gustavo.

> > Use the more common logging styles.
> > bt_print uses vsprintf extension %pV.
> > This saves 2 to 3 % of code/text space.
> > $ find net/bluetooth -name "built-in.o.*" | xargs size
> > text data bss dec hex filename
> > 14778 1012 3408 19198 4afe net/bluetooth/bnep/built-in.o.new
> > 15067 1012 3408 19487 4c1f net/bluetooth/bnep/built-in.o.old
> > 18483 1172 4264 23919 5d6f net/bluetooth/cmtp/built-in.o.new
> > 18927 1172 4264 24363 5f2b net/bluetooth/cmtp/built-in.o.old
> > 59461 3884 14464 77809 12ff1 net/bluetooth/rfcomm/built-in.o.new
> > 61206 3884 14464 79554 136c2 net/bluetooth/rfcomm/built-in.o.old
> > 19237 1172 5152 25561 63d9 net/bluetooth/hidp/built-in.o.new
> > 19581 1172 5152 25905 6531 net/bluetooth/hidp/built-in.o.old
> > 346600 19163 86080 451843 6e503 net/bluetooth/built-in.o.new
> > 353751 19163 86064 458978 700e2 net/bluetooth/built-in.o.old
> > $ find drivers/bluetooth/ -name "built-in.o.*" | xargs size
> > text data bss dec hex filename
> > 129956 8632 36096 174684 2aa5c drivers/bluetooth/built-in.o.new
> > 134402 8632 36064 179098 2bb9a drivers/bluetooth/built-in.o.old
> This is really nice, but can we keep the lower case?

I don't understand what you mean.
Maybe "keep the upper case"?

Sure, go for it.

My point was to add bt_printk and convert the macros.
You could break that up into 5 patches I suppose.

Some sequence like:

Add bt_printk, convert current BT_<LEVEL> to use them
Rename bt_err to bt_to_errno
Add lowercase bt_<level>
Case conversions of BT_<LEVEL> to bt_<level>
Remove BT_<LEVEL>

> I think applying this
> patch now will break things to people developing on top of my tree.

Do what you think best.
The code size saving is in conversion to bt_printk and using %pV.
The UPPER->lower is noisy and trivial.

> Then someday in the future when development becomes calm or just after the
> next merge window I run a s/BT_*/bt_*/ on everything.
> Thanks a lot for looking into this, reduce code/text by 3% only changing
> logging is awesome.

cheers, Joe



\
 
 \ /
  Last update: 2011-06-30 05:51    [W:0.050 / U:0.500 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site