lkml.org 
[lkml]   [2011]   [Jun]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [stable] Please revert "iwlagn: Support new 5000 microcode." from 2.6.32 and 2.6.33
On Tue, Jun 14, 2011 at 10:14:44PM -0300, Herton Ronaldo Krzesinski wrote:
> On Tue, Jun 14, 2011 at 04:03:44PM -0700, Greg KH wrote:
> > On Mon, Jun 13, 2011 at 03:13:18PM -0300, Herton Ronaldo Krzesinski wrote:
> > > The patch ("iwlagn: Support new 5000 microcode") shoudn't have been
> > > applied on 2.6.32 and 2.6.33 stable trees, it doesn't support new
> > > firmware file format, thus if the new firmware is on the disk, loading
> > > fails, as reported on:
> > > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/796336
> > >
> > > Support for the iwlagn new firmware file format was only added beginning
> > > with 2.6.35 (commit "iwlagn: implement loading a new firmware file
> > > type"), so iwlagn works with new firmware only with 2.6.35 or later.
> >
> > Can I get an ack from the developer of the patch and the people involved
> > with it first? It was asked to be backported for a reason, so I would
> > at least like to get the people who asked for the backport to have a
> > chance to respond please.
> >
> > It's only nice, why would you exclude them?
>
> I didn't intend to exclude anyone and I'm just reporting it, it didn't
> came to my mind CC'ing people while sending to stable, and hopefully
> everyone related are CC'ed now.
>
> Also note that this revert request is for 2.6.32 and 2.6.33 *only*
>
> And seems the right thing to do for them.
>
> The other stable release where this was applied (2.6.35) looks fine
> but these two are too old to support the new firmware (don't work, need
> extra patches backported which weren't, like the commit I mentioned --
> commit "iwlagn: implement loading a new firmware file type"), as yourself
> can check reading the code/bug report, and what I wrote.

ACK for revert. I could be wrong, but I think some more patches, except mentioned
new format patch, are needed to make driver work reliably with the new firmware.

Stanislaw


\
 
 \ /
  Last update: 2011-06-15 07:59    [W:0.043 / U:1.316 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site