[lkml]   [2011]   [Jun]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 3/8] MFD: twl4030-audio: Rename platform data
* Peter Ujfalusi <> [110601 05:50]:
> On Wednesday 01 June 2011 15:07:54 Tony Lindgren wrote:
> >
> > Can you please take a look at creating arch/arm/mach-omap2/i2c-twl.c or
> > something in common-board-devices.c to get rid of the cut and paste
> > duplication in every board-*.c file?
> Yes, it would make sense, since most of the board has similar configuration,
> and we have lots of duplicated code around.
> > Maybe you could have a generic twl_init function that allows overriding
> > things like keypad with board specific configuration?
> We might need also support for overriding other configurations
> (audio/codec/vibra for sure needs that).

Yeah, most of it might be possible to describe with just a flags
like TWL_HAS_VIBRA etc.

> I'll take a look, but I think it is not going to be part of v2 of this series.

We should not do renaming before the clean-up though, it gets
classified as "unnecesary churn".


 \ /
  Last update: 2011-06-01 15:03    [W:0.042 / U:4.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site