[lkml]   [2011]   [May]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [block IO crash] Re: 2.6.39-rc5-git2 boot crashs
On Wed, May 4, 2011 at 12:30 PM, Christoph Lameter <> wrote:
> The naming convention came about from the existing this_cpu_xxx
> operations

You're missing my point.

An "add" operation makes sense even if it isn't atomic, because
atomicity isn't a part of the definition of "add".

But cmpxchg DOES NOT MAKE SENSE without atomicity guarantees.

The whole operation is about atomicity.

Having a version that isn't atomic is STUPID. It's misleading. It's _wrong_.

In contrast, having a non-atomic "add" version is understandable.

So when you say "naming convention", you're missing the much bigger
naming convention. Namely the "cmpxchg" part!


 \ /
  Last update: 2011-05-04 21:47    [W:0.103 / U:4.216 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site