[lkml]   [2011]   [May]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH v5 03/21] evm: re-release
    Quoting Mimi Zohar (
    > +extern int evm_hmac_size;
    > +int evm_hmac_size = SHA1_DIGEST_SIZE;

    I think I object to having both MAX_DIGEST_SIZE and evm_hmac_size, both
    of which are set to SHA1_DIGEST_SIZE throughout this patchset. Especially
    because of the comment I was about to make on patch 4/21, where you
    then prepend the hmac with a 'type' byte, and start passing around
    MAX_DIGEST_SIZE+1 and evm_hmac_size+1.

    Even if you're going to be using those differently in a later patchset,
    let's focus on this set for now and keep things simpler. One constant
    for the hmac size, and then please define a new one (in patch 4) for
    the annotated digest size. I can't think think of a good name. Which
    suggests that perhaps you should define a nicely typed struct to contain
    the header+hmac...

    I see no other problems, so presuming that these are nicely addressed
    I expect to happily ack.


     \ /
      Last update: 2011-05-19 23:41    [W:0.019 / U:1.792 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site