lkml.org 
[lkml]   [2011]   [Apr]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1/2] rename alloc_pages_exact()
From
Date
On Thu, 2011-04-07 at 14:40 -0700, David Rientjes wrote:
> > alloc_pages_exact() returns a virtual address. But, alloc_pages() returns
> > a 'struct page *'. That makes for very confused kernel hackers.
> >
> > __get_free_pages(), on the other hand, returns virtual addresses. That
> > makes alloc_pages_exact() a much closer match to __get_free_pages(), so
> > rename it to get_free_pages_exact().
> >
>
> The patch also reverses the arguments of the function in
> include/linux/gfp.h, undoubtedly to resemble the (mask, order) appearance
> of __get_free_pages():
>
> -void *alloc_pages_exact(size_t size, gfp_t gfp_mask);
> +void *get_free_pages_exact(gfp_t gfp_mask, size_t size);

Thanks. I dumped the fixes for that in the second patch. Whoops. Will
repost.

-- Dave



\
 
 \ /
  Last update: 2011-04-08 00:01    [W:0.329 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site