lkml.org 
[lkml]   [2011]   [Apr]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[PATCHSET] signals-review branch
Hello.

I collected the patches which were acked by Tejun and Matt and (I hope)
Linus agrees with,

git://git.kernel.org/pub/scm/linux/kernel/git/oleg/misc.git signals-review

[PATCH 01/13] signal: introduce retarget_shared_pending()
[PATCH 02/13] signal: retarget_shared_pending: consider shared/unblocked signals only
[PATCH 03/13] signal: retarget_shared_pending: optimize while_each_thread() loop
[PATCH 04/13] signal: sigprocmask: narrow the scope of ->siglock
[PATCH 05/13] signal: sigprocmask() should do retarget_shared_pending()
[PATCH 06/13] x86: signal: handle_signal() should use set_current_blocked()
[PATCH 07/13] x86: signal: sys_rt_sigreturn() should use set_current_blocked()
[PATCH 08/13] signal: cleanup sys_rt_sigprocmask()
[PATCH 09/13] signal: sys_rt_sigtimedwait: simplify the timeout logic
[PATCH 10/13] signal: introduce do_sigtimedwait() to factor out compat/native code
[PATCH 11/13] signal: do_sigtimedwait() needs retarget_shared_pending()
[PATCH 12/13] signal: rename signandsets() to sigandnsets()
[PATCH 13/13] signal: cleanup sys_sigprocmask()

I do not want to spam lkml again, all changes are purely cosmetic and hopefully
address the comments from you and Matt:

all: rediff against ptrace branch

[PATCH 02/13] signal: retarget_shared_pending: consider shared/unblocked signals only
commit f646e227b88a164a841d6b6dd969d8a45272dd83

retarget_shared_pending:

s/set/which/, s/shared_pending/retarget

exit_signals:

s/set/unblocked

[PATCH 03/13] signal: retarget_shared_pending: optimize while_each_thread() loop
commit fec9993db093acfc3999a364e31f8adae41fcb28

retarget_shared_pending:

remove the unnecessary () in "if ((t->flags & PF_EXITING))"

add the small comment

[PATCH 05/13] signal: sigprocmask() should do retarget_shared_pending()
commit e6fa16ab9c1e9b344428e6fea4d29e3cc4b28fb0

set_current_blocked:

add some comments

[PATCH 07/13] x86: signal: sys_rt_sigreturn() should use set_current_blocked()
commit e9bd3f0faa90084f188830d77723bafe422e486b

no changes. I was asked to add the comment, but I have no
idea what should be documented. The patch and the code are
trivial.

[PATCH 08/13] signal: cleanup sys_rt_sigprocmask()
commit bb7efee2ca63b08795ffb3cda96fc89d2e641b79

do not touch the "XXX" comment which I misunderstood

[PATCH 10/13] signal: introduce do_sigtimedwait() to factor out compat/native code
commit 943df1485a8ff0e600729e082e568ece04d4de9e

Well. As it was suggested, I added the docbook coment to the
new helper. Trivial copy-and-paste from sys_rt_sigtimedwait(),
not sure we need these extra 6 lines.

Unless you have other comments, I'll merge this into ptrace branch.

Oleg.



\
 
 \ /
  Last update: 2011-04-28 17:29    [W:1.280 / U:0.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site