lkml.org 
[lkml]   [2011]   [Apr]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Regression?] Removed regulator support in ehci-omap
On 04/24/2011 02:37 AM, Keshava Munegowda wrote:
>> -----Original Message-----
>> From: Alan Ott [mailto:alan@signal11.us]
>> Sent: Friday, April 22, 2011 6:41 AM
>> To: Keshava Munegowda
>> Cc: Dmitry Artamonow; Steve Sakoman; Steve Calfee; Felipe Balbi;
> linux-usb@vger.kernel.org; linux-
>> omap@vger.kernel.org; linux-kernel@vger.kernel.org
>> Subject: Re: [Regression?] Removed regulator support in ehci-omap
>>
>> On 04/12/2011 12:20 PM, Keshava Munegowda wrote:
>>>> Ah, so EHCI/OHCI common code was moved into drivers/mfd... Good.
>>>> But seems regulators support was lost somewhere during transition -
> the
>>>> only mentioning about regulators in omap-usb-host.c is "#include" :
>>>>
>>>> mad@macmini:~/kernel-hack/linux-2.6(master)$ grep -i regulator
>>> drivers/mfd/omap-usb-host.c
>>> Thanks ! I will add some time next week!
>> I have confirmed this on my BeagleBoard-xM. 2.6.38 works, but the
>> 2.6.39-rc4+ head from yesterday did not. It seems that the regulator
>> does not turn the power on for the USB hub which the ethernet is
>> attached to.
>>
>> I connected this issue to bug 33092 in bugzilla[1].
>>
>> Alan.
>>
>> [1] https://bugzilla.kernel.org/show_bug.cgi?id=33092
> I have posted the patches on April 22, 2011.
> If possible I request you to test this.

Hi Keshava,

If you mean this patch[1], then I tested it against the head and it
didn't fix my problem. I couldn't convince myself that your patch was
supposed to be the whole fix to my problem (since it wasn't mentioned on
this thread) so I didn't reply with my findings. Sorry about that.

Thanks for taking a look,

Alan.

[1] http://www.spinics.net/lists/linux-usb/msg45618.html


[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2011-04-25 16:13    [from the cache]
©2003-2011 Jasper Spaans