lkml.org 
[lkml]   [2011]   [Apr]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Build regressions/improvements in v2.6.39-rc3
From
Date
On Wed, 2011-04-13 at 19:38 +0200, Geert Uytterhoeven wrote:
> On Wed, Apr 13, 2011 at 19:32, David Miller <davem@davemloft.net> wrote:
> > From: Geert Uytterhoeven <geert@linux-m68k.org>
> > Date: Wed, 13 Apr 2011 18:35:45 +0200 (CEST)
> >
> >> 47 regressions:
> >> + build/linus_sparc64-allmodconfig_sparc64/usr/include/linux/ethtool.h: error: expected specifier-qualifier-list before '__u32': 104, 90, 21, 282, 389, 460, 521, 444, 96, 297, 82, 57, 291, 258, 231, 482, 209, 510, 265, 113 => 104, 538, 90, 21, 523, 552, 266, 445, 292, 96, 82, 512, 563, 57, 259, 283, 298, 484, 390, 231, 209, 462, 574, 113
> >
> > I do allmodconfig builds on sparc64 systems every single day using
> > various versions of gcc-4.4, gcc-4.5, and gcc-4.6
> >
> > And I never ever see this build error. Never.
> >
> > If you're using a cross build environment, maybe something isn't quite
> > right with that?
>
> As it mentions `/usr/include/linux/ethtool.h', it seems to be an
> include that's part of the
> cross build environment.
>
> I'm just using the logs from the linux-next build service...

Which is just using the cross compilers that Tony builds ...

I'll have a look and see if we can work out what the problem is.

cheers
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2011-04-14 02:07    [W:0.048 / U:5.880 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site