[lkml]   [2011]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC][PATCH] axi: add AXI bus driver
2011/4/12 Rafał Miłecki <>:
> Cc: Michael Büsch <>
> Cc: Larry Finger <>
> Cc: George Kashperko <>
> Cc: Arend van Spriel <>
> Cc:
> Cc: Russell King <>
> Cc: Arnd Bergmann <>
> Cc: Andy Botting <>
> Cc: linuxdriverproject <>
> Cc: <>
> Signed-off-by: Rafał Miłecki <>
> ---
> V2: Rename to axi
>    Use DEFINE_PCI_DEVICE_TABLE in bridge
>    Make use of pr_fmt and pr_*
>    Store core class
>    Rename bridge to not b43 specific
>    Replace magic 0x1000 with BCMAI_CORE_SIZE
>    Remove some old "ssb" names and defines
>    Move BCMAI_ADDR_BASE def
>    Add drvdata field
> V3: Fix reloading (kfree issue)
>    Add 14e4:0x4331
>    Fix non-initialized struct issue
>    Drop useless inline functions wrappers for pci core drv
>    Proper pr_* usage
> V3.1: Include forgotten changes (pr_* and include related)
>    Explain why we dare to implement empty release function

There is one more change I started to consider. Is "core" correct name
for AXI's device? Almost everywhere we can read about *components* on
the AXI interconnect.

Maybe it'd make sense to s/core/comp/? Arend?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2011-04-12 15:07    [W:0.060 / U:2.760 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site