lkml.org 
[lkml]   [2011]   [Mar]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [GIT PULL] Core block IO bits for 2.6.39 - early Oops
On 2011.03.24 at 20:36 +0100, Jens Axboe wrote:
> On 2011-03-24 20:34, Markus Trippelsdorf wrote:
> > On 2011.03.24 at 19:58 +0100, Jens Axboe wrote:
> >> On 2011-03-24 19:54, Markus Trippelsdorf wrote:
> >>> On 2011.03.24 at 19:51 +0100, Jens Axboe wrote:
> >>>> On 2011-03-24 19:36, Jens Axboe wrote:
> >>>>> On 2011-03-24 19:30, Markus Trippelsdorf wrote:
> >>>>>> On 2011.03.24 at 14:43 +0100, Jens Axboe wrote:
> >>>>>>>
> >>>>>>> This is the main pull request for the block IO layer and friends for
> >>>>>>> 2.6.39.
> >>>>>>
> >>>>>> This merge results in an early oops on my system (amd64, xfs).
> >>>>>> See the attached photo.
> >>>>>>
> >>>>>
> >>>>> Auch. Can you ensure that you have CONFIG_DEBUGINFO=y in your .config
> >>>>> and then do:
> >>>>>
> >>>>> $ gdb vmlinux
> >>>>> ...
> >>>>> l *cfq_insert_request+0x32
> >>>>>
> >>>>> and send that output?
> >>>>
> >>>> I took a closer look at the oops, and it most likely looks like q ==
> >>>> NULL (offset 0x18 == q->elevator). You left out the Code part, so I
> >>>> can't verify that for certain. Which makes very little sense. I take it
> >>>> this is 100% reproducible? When you send the gdb output, please also
> >>>> attach your .config.
> >>>
> >>> Yes, it's 100% reproducible here. My .config follows:
> >>
> >> Can you try this patch and see if it makes a difference?
> >
> > There's no patch ;-)
>
> Oh, here it is.
>
It doesn't help, unfortunately. I still get the same BUG at
cfq_insert_request+0x32/0x4d0.

--
Markus


\
 
 \ /
  Last update: 2011-03-24 20:47    [from the cache]
©2003-2011 Jasper Spaans