lkml.org 
[lkml]   [2011]   [Mar]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [2.6.38-rc6] G965: i915 Hangcheck timer elapsed... GPU hung (not reproducible)

(cc dri-devel)

A post-2.6.37 regression.

On Sun, 27 Feb 2011 10:10:41 +0100
Paolo Ornati <ornati@gmail.com> wrote:

> Today I got this while starting a video in SMplayer (MPlayer) with
> 2.6.38-rc6-00113-g4662db4:
>
> [ 830.880014] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
> [ 830.880736] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 174895 at 174857, next 174896)
> [ 830.881093] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 00000000 head 00000000 tail 00000000 start 00000000
> [ 831.379079] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling
> [ 831.399099] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling
> ...
> [ 837.392012] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
> [ 837.392038] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 175016 at 174857, next 175022)
> [ 837.392491] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 00000000 head 00000000 tail 00000000 start 00000000
> [ 837.537479] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling
> [ 837.543285] [drm:i915_do_wait_request] *ERROR* something (likely vbetool) disabled interrupts, re-enabling
> ...
> [ 839.040011] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
> [ 839.040034] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 175022 at 174857, next 175122)
> [ 839.040364] [drm:i915_reset] *ERROR* GPU hanging too fast, declaring wedged!
> [ 839.040367] [drm:i915_reset] *ERROR* Failed to reset chip.
>
> Screen was almost freezed, cursor was stuck but the machine was alive
> and I was able to use SysRq to kill X and try to restart it (but that
> didn't help).
>
> I don't remember anything similar in recent kernels (<= 2.6.37) and got
> this only once with 2.6.38-rcX.
>
> Environment at the time of the GPU crash:
> KDE4 (without "Desktop Effects")
> Chromium
> Claws Mail
> Dolphin
> ccached make -j3 on a just pulled linux-tree (so I/O bound)
> SMPlayer/Mplayer (just launched)
>
> Assorted logs attached.
>



\
 
 \ /
  Last update: 2011-03-03 00:59    [W:0.067 / U:28.652 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site