lkml.org 
[lkml]   [2011]   [Mar]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] uio_netx: Add support for netPLC cards
On Thu, Mar 17, 2011 at 11:40:59AM +0000, Daniel Trautmann wrote:
> This patch adds support for Hilscher / IBHsoftec netPLC cards to uio_netx userspace IO driver.
>
> Signed-off-by: Daniel Trautmann <dtrautmann@ibhsoftec-sps.de>
> ---
> drivers/uio/uio_netx.c | 19 +++++++++++++++++++
> 1 files changed, 19 insertions(+), 0 deletions(-)

Against what kernel is that supposed to apply? It doesn't apply against
Linus' current tree here.

And, please, run your patch through scripts/checkpatch.pl before posting it.

I get:
-----------------------
total: 15 errors, 16 warnings, 37 lines checked

NOTE: whitespace errors detected, you may wish to use scripts/cleanpatch or
scripts/cleanfile
-----------------------
I find 15 errors in 19 insertions a bit too much. Most of it is whitespace,
so it might be a problem with your mail client. Please check.

>
> diff --git a/drivers/uio/uio_netx.c b/drivers/uio/uio_netx.c
> index 5ffdb48..7921190 100644
> --- a/drivers/uio/uio_netx.c
> +++ b/drivers/uio/uio_netx.c
> @@ -18,6 +18,9 @@
>
> #define PCI_VENDOR_ID_HILSCHER 0x15CF
> #define PCI_DEVICE_ID_HILSCHER_NETX 0x0000
> +#define PCI_DEVICE_ID_HILSCHER_NETPLC 0x0010

Hmpf, yes... The three defines above should go to include/linux/pci_ids.h

I should have done that from the beginning, could you fix it now?

> +#define PCI_SUBDEVICE_ID_NETPLC_RAM 0x0000
> +#define PCI_SUBDEVICE_ID_NETPLC_FLASH 0x0001
> #define PCI_SUBDEVICE_ID_NXSB_PCA 0x3235
> #define PCI_SUBDEVICE_ID_NXPCA 0x3335
>
> @@ -66,6 +69,10 @@ static int __devinit netx_pci_probe(struct pci_dev *dev,
> bar = 0;
> info->name = "netx";
> break;
> + case PCI_DEVICE_ID_HILSCHER_NETPLC:
> + bar = 0;
> + info->name = "netplc";
> + break;
> default:
> bar = 2;
> info->name = "netx_plx";
> @@ -133,6 +140,18 @@ static struct pci_device_id netx_pci_ids[] = {
> .subvendor = 0,
> .subdevice = 0,
> },
> + {
> + .vendor = PCI_VENDOR_ID_HILSCHER,
> + .device = PCI_DEVICE_ID_HILSCHER_NETPLC,
> + .subvendor = PCI_VENDOR_ID_HILSCHER,
> + .subdevice = PCI_SUBDEVICE_ID_NETPLC_RAM,
> + },
> + {
> + .vendor = PCI_VENDOR_ID_HILSCHER,
> + .device = PCI_DEVICE_ID_HILSCHER_NETPLC,
> + .subvendor = PCI_VENDOR_ID_HILSCHER,
> + .subdevice = PCI_SUBDEVICE_ID_NETPLC_FLASH,
> + },
> {
> .vendor = PCI_VENDOR_ID_PLX,
> .device = PCI_DEVICE_ID_PLX_9030,
>

Otherwise, the patch looks alright to me. Please post a new version that
applies against the current kernel, and fix the whitespace errors. If it is
a problem with your mail client, you should send the mail to yourself first.
Save it, and run it through checkpatch.

Thanks,
Hans



\
 
 \ /
  Last update: 2011-03-19 01:15    [W:0.041 / U:4.312 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site