lkml.org 
[lkml]   [2011]   [Mar]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Firmware works I think, why my networking fails?
On 18.03.2011 12:34, Piotr Hosowicz wrote:
> Hello,
>
> The 2.6.39-git3 kernel works as usual, mii-tool shows that there is
> link. Any newer kernel fails this test. What can I do? What extra
> information would you need?

Here is some more ethtool info, when cannot connect through ADSL via eth0:

aapi205:~# cat eth0.et.BAD.txt
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 1000baseT/Half 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 10Mb/s
Duplex: Half
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: no

Regards,

Piotr Hosowicz

--
TV: "Gruchała jest taka, że cieszy się z każdego pchnięcia."
NP: Banda Do Sol - Tempo
NB: 2.6.38-git3
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2011-03-18 15:09    [W:0.029 / U:8.740 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site