lkml.org 
[lkml]   [2011]   [Mar]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRe: reboot/kexec in 2.6.38
    Cyril Hrubis <metan@ucw.cz> writes:

    > Hi!
    >> > I got report that  reboot/kexec does not work in recent kernels.
    >> >
    >> > I tried both kexec and reboot in 2.6.38, and it worked ok. Maybe
    >> > config issue?
    >>
    >> I think it's config issue. Never heard of this.
    >>
    >
    > I've seen that on my zaurus a month or two ago. When kexeced to pxa-linux-2.6
    > then tried to kexec again. The last thing I've seen was Bye on the framebuffer
    > console and the machine freezed.

    The basic kexec code has been stable and solid for a long time so kexec
    failures are almost always hardware interaction problems.

    Someone not stopping dma, or someone not putting the hardware in a state
    that the next kernel can figure out how to initialize it.

    Eric
    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2011-03-17 18:09    [W:0.024 / U:0.176 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site