lkml.org 
[lkml]   [2011]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    SubjectRe: [PATCH] kbuild: Fix computing srcversion for modules
    From
    On 12 March 2011 02:06, Henrik Rydberg <rydberg@euromail.se> wrote:
    > On Fri, Mar 11, 2011 at 10:34:47PM +0100, Michal Marek wrote:
    >> Recent change to fixdep:
    >>
    >>     commit b7bd182176960fdd139486cadb9962b39f8a2b50
    >>     Author: Michal Marek <mmarek@suse.cz>
    >>     Date:   Thu Feb 17 15:13:54 2011 +0100
    >>
    >>     fixdep: Do not record dependency on the source file itself
    >>
    >> changed the format of the *.cmd files without realizing that it is also
    >> used by modpost. Put the path to the source file to the file back, in a
    >> special variable, so that modpost sees all source files when calculating
    >> srcversion for modules.
    >>

    Hi Michal,

    There is something wrong with the patch,
    I can't compile 2.6.38 neither linux-next on sparc64:

    $ make CROSS_COMPILE=sparc64-unknown-linux-gnu-
    CHK include/linux/version.h
    CHK include/generated/utsrelease.h
    UPD include/generated/utsrelease.h
    CC kernel/bounds.s
    GEN include/generated/bounds.h
    CC arch/sparc/kernel/asm-offsets.s
    GEN include/generated/asm-offsets.h
    CALL scripts/checksyscalls.sh
    CC scripts/mod/empty.o
    MKELF scripts/mod/elfconfig.h
    HOSTCC scripts/mod/file2alias.o
    HOSTCC scripts/mod/modpost.o
    HOSTCC scripts/mod/sumversion.o
    HOSTLD scripts/mod/modpost
    /usr/lib/gcc/sparc-unknown-linux-gnu/4.5.2/../../../../sparc-unknown-linux-gnu/bin/ld:
    scripts/mod/sumversion.o: Relocations in generic ELF (EM: 3)
    scripts/mod/sumversion.o: could not read symbols: File in wrong format
    collect2: ld returned 1 exit status

    $ file scripts/mod/sumversion.o
    scripts/mod/sumversion.o: ELF 32-bit LSB relocatable, Intel 80386,
    version 1 (SYSV), not stripped

    Why 386?

    gcc both sparc and sparc64 are 4.5.2, ld/binutils is 2.21
    --
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2011-03-15 06:07    [W:0.043 / U:29.968 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site