[lkml]   [2011]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 21/21] tcm_loop: Add multi-fabric Linux/SCSI LLD fabric module
On Mon, Mar 14, 2011 at 03:02:55PM -0700, Nicholas A. Bellinger wrote:
> > Please descide on a naming scheme for the frontend modules. You have
> > tcm_loop for thise one, and just iscsi for the iscsi frontend.
> Ok, curently everything that appears under drivers/target/ beside
> iscsi_target_mod.ko is using a matching drivers/target/$FABRIC_MOD/ and
> $FABRIC_MOD.ko naming scheme.
> I would prefer to keep iscsi_target_mod.ko for the software iSCSI case
> in order to prevent chaos with existing userspace tools and prevent
> breakage with existing other iSCSI target modules (IET is using
> iscsi_trgt.ko IIRC).
> How about dropping the 'tcm_' prefix from the drivers/target/tcm_subdir/
> to follow how the fabric module actually appears once loaded under
> /sys/kernel/config/target/$FABRIC/..? We will need to keep the common
> 'tcm_' prefix for the actual target fabric modules (or choose a
> different one) to handle those that interface with existing SCSI LLD
> code.

Dropping the tcm sounds fine to me.

> This makes it a bit easier to grok as a reference for newcomers by
> having seperate sections for configfs control plane, struct
> target_core_fabric_ops API callers, and Linux/SCSI LLD specific glue.

I don't think it's a very good reference, though. E.g. currently the
fabric ops methods are implemented in tcm_loop_fabric.c, and all need
non-static scope because they are assigned in tcm_loop_configfs.c, which
creates a lot of global scope and pointless prototypes. Either one
could clean all that up or just merge the files into one which would
be a lot easier. Especiall as the way the target_fabric_configfs structure
and the fabric ops are structured will get a big overhaul from me soon.

 \ /
  Last update: 2011-03-15 11:21    [W:0.073 / U:3.312 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site