lkml.org 
[lkml]   [2011]   [Mar]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [REGRESSION] tpm_tis on Lenovo T410 broken in 2.6.38-rc6
From
Date

On Mar 1, 2011, at 8:54 AM, Rajiv Andrade wrote:

>
> The previously reverted commit makes the TPM device driver get the returned timeouts correctly. However, some TPMs return such values in msecs instead of usecs, causing some commands to timeout (e.g the TPM_SaveState, sent at suspend). There's a reworked version of the tpm_tis: Use timeouts returned from TPM patch that adjusts these short timeouts automatically, can you check if it works for you?
>
> git://tpmdd.git.sourceforge.net/gitroot/tpmdd/tpmdd/ for-james
>
>

Just to clarify, I'm using a version of Linus's upstream that already had the first commit ("Use timeouts returned fromTPM") disabled. However, when things broke, I saw that reverting the "Long default timeouts fix" caused me to no longer get "timeout" errors, and my TPM software started working again, so I could connect to the intranet.

> I don't know however why the second commit you reverted still caused the timeouts, I have the same machine here. Did you test both patches with TPM interrupts disabled? (with tpm_tis interrupts option set to 0)

I tested with no options; until you mentioned it, I didn't even know that this module parameter existed, and it was something I should try toggling. I was just a normal schlub who tried pulling the latest Linus tree, tried using it, and got a broken TPM.

So tell me what to test, and exactly how to test it, and I'm happy to run experiments for you. Do you want me to take Linus's latest upstream (which has one TPM patch reverted), apply your for-james patch, and then try with and without tpm_tis's interrupts option set to zero? I assume that means adding modprobe options parameter interrupts=0?

-- Ted




\
 
 \ /
  Last update: 2011-03-01 16:47    [W:0.071 / U:4.904 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site