lkml.org 
[lkml]   [2011]   [Feb]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/3] x86-64: use relative 32-bit pointers in exception tables

Nice patch. I've got a really small code readability nitpick:

> +#ifndef ex_insn /* until all architectures have this accessor */
> +#define ex_insn(x) (x)->insn
> +#endif

> +#else
> +#define swap_ex NULL
> +#endif

In the x86 architecture we tend to write this as:

> +#else
> +# define swap_ex NULL
> +#endif

So that the conditional structure stands out more, visually. (There might be more
such cases in these patches as well.)

Thanks,

Ingo


\
 
 \ /
  Last update: 2011-02-17 18:29    [W:0.079 / U:0.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site