lkml.org 
[lkml]   [2011]   [Nov]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] config: Add 'make kvmconfig'

* Michal Marek <mmarek@suse.cz> wrote:

> On 2.11.2011 10:17, Ingo Molnar wrote:
> > * Michal Marek <mmarek@suse.cz> wrote:
> >> On 2.11.2011 09:41, Ingo Molnar wrote:
> >>> Yeah. Note that it's more like an 'add' operation, not a modify
> >>> operation, thus:
> >>>
> >>> make addconfig=kvm
> >>>
> >>> or:
> >>>
> >>> make addconfig kvm
> >>>
> >>> would be intuitive and would work well too.
> >>>
> >>> Sam, Michal, which one would you prefer? The latter might have the
> >>> advantage that it's additive, enabling future usages like:
> >>>
> >>> make addconfig kvm debug
> >>
> >> The problem is that neither of these fit into the make command syntax:
> >>
> >> make addconfig kvm debug
> >>
> >> tells make to build three different targets, and
> >>
> >> make addconfig=kvm
> >>
> >> tells make to create a variable named addconfig with the value kvm
> >> and build the default target. And BTW, you or someone else
> >> reassured me earlier in the thread that this is going to be needed
> >> for the kvm case solely, so why are you inventing something generic
> >> now? :)
> >
> > Because we are trying to find *something* that is both usable and
> > which you guys are willing to ack.
> >
> > So what's your suggestion? Is 'make kvmconfig' OK?
>
> As I said, make kvmconfig is fine with me, if it's just this single case.
>
> Michal

Great, thanks!

Ingo


\
 
 \ /
  Last update: 2011-11-02 10:47    [W:0.042 / U:1.176 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site