lkml.org 
[lkml]   [2011]   [Nov]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] mfd: twl4030-audio: Fix audio codec breakage
Date
On Wednesday 19 October 2011 11:44:05 Jarkko Nikula wrote:
> Commit 57fe725 ("MFD: twl4030-codec -> twl4030-audio: Rename the driver")
> broke the device registration for twl4030 codec if twl6040 is not set.
>
> Reason for breakage is that commit didn't update the changed config name for
> macro twl_has_codec().
>
> Signed-off-by: Jarkko Nikula <jarkko.nikula@bitmer.com>
> Cc: Peter Ujfalusi <peter.ujfalusi@ti.com>
> ---
> I don't know is this too late for 3.1 or would it be better to queue for
> stable when it's out? Anyway breakage happened in 3.1-rc cycle and
> unfortunately I noticed it only now.

Thanks Jarkko for noticing this. I have overlooked it probably because I'm
using omap2plus_defconf for most of the time.

The breakage also present in 3.0. Can we queue this patch for stable 3.0.x,
and 3.1.x?

Acked-by: Peter Ujfalusi <peter.ujfalusi@ti.com>

> ---
> drivers/mfd/twl-core.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
> index 01ecfee..b8eef46 100644
> --- a/drivers/mfd/twl-core.c
> +++ b/drivers/mfd/twl-core.c
> @@ -109,7 +109,7 @@
> #define twl_has_watchdog() false
> #endif
>
> -#if defined(CONFIG_TWL4030_CODEC) || defined(CONFIG_TWL4030_CODEC_MODULE)
> ||\ +#if defined(CONFIG_MFD_TWL4030_AUDIO) ||
> defined(CONFIG_MFD_TWL4030_AUDIO_MODULE) ||\ defined(CONFIG_TWL6040_CORE)
> || defined(CONFIG_TWL6040_CORE_MODULE) #define twl_has_codec() true
> #else



\
 
 \ /
  Last update: 2011-11-02 08:43    [W:0.050 / U:8.724 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site