lkml.org 
[lkml]   [2011]   [Nov]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRE: [PATCH v2] pinctrl: indicate GPIO direction on single GPIO request
Igor Grinberg wrote at Thursday, November 17, 2011 8:29 AM:
> You haven't responded to my request for the previous version...
> Pleaser, see below:
>
> On 11/17/11 15:46, Linus Walleij wrote:
> > From: Linus Walleij <linus.walleij@linaro.org>
...
> > static int pin_request(struct pinctrl_dev *pctldev,
> > int pin, const char *function,
> > - struct pinctrl_gpio_range *gpio_range)
> > + struct pinctrl_gpio_range *gpio_range,
> > + bool gpio_direction)
>
> can this (and other instances) be:
> s/gpio_direction/gpio_direction_out/
> ?
> Because "gpio_direction == true/false" does not make much sense.
> OTOH, "gpio_direction_out == true/false" does make sense.

I agree with this sentiment.

Bikeshedding a little, but is_output is shorter and just as explanatory
to me.

--
nvpublic



\
 
 \ /
  Last update: 2011-11-17 18:05    [from the cache]
©2003-2011 Jasper Spaans