lkml.org 
[lkml]   [2011]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h
Hi Sangwook,

On 11/15/2011 01:23 PM, Sangwook Lee wrote:
> The patch series proposes to rename ath9k_platform.h to "ath_platform.h
> This header file handles platform data used only for ath9k,
> but it can used by ath6k as well. We can take "wl12xx.h" as
> as a example. Please let us change this file name so that
> other Atheors WLANs use this file for their own platform data

ath9k and ath6kl are very different devices, I'm not sure if sharing a
platfrom struct between the two is really a good idea. Most likely there
is very little the two drivers can share. What are your plans here?

I myself was thinking that we would have include/linux/ath6kl.h
dedicated just for ath6kl. That would makes things simpler.

Kalle


\
 
 \ /
  Last update: 2011-11-15 17:47    [from the cache]
©2003-2011 Jasper Spaans