lkml.org 
[lkml]   [2011]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH V2 2/6] net/ethernet/atl1e: Disable ASPM
From
From: David Miller <davem@davemloft.net>
Date: Mon, 14 Nov 2011 00:31:13 -0500 (EST)

> From: Matthew Garrett <mjg@redhat.com>
> Date: Fri, 11 Nov 2011 11:14:20 -0500
>
>> http://www.atheros.cz/atheros-inf-file.php?inf=209&chipset=45&system=6
>> indicates that ASPM is disabled on all L1E hardware. Duplicate for sanity.
>>
>> Signed-off-by: Matthew Garrett <mjg@redhat.com>
>
> Applied.

Ummm, -ENOBUILDTESTING?!??!

drivers/net/ethernet/atheros/atl1e/atl1e_main.c: In function ‘atl1e_probe’:
drivers/net/ethernet/atheros/atl1e/atl1e_main.c:2267:2: error: implicit declaration of function ‘pci_disable_link_state’ [-Werror=implicit-function-declaration]
drivers/net/ethernet/atheros/atl1e/atl1e_main.c:2267:31: error: ‘PCIE_LINK_STATE_L0S’ undeclared (first use in this function)
drivers/net/ethernet/atheros/atl1e/atl1e_main.c:2267:31: note: each undeclared identifier is reported only once for each function it appears in
drivers/net/ethernet/atheros/atl1e/atl1e_main.c:2267:53: error: ‘PCIE_LINK_STATE_L1’ undeclared (first use in this function)
drivers/net/ethernet/atheros/atl1e/atl1e_main.c:2268:11: error: ‘PCIE_LINK_STATE_CLKPM’ undeclared (first use in this function)
\
 
 \ /
  Last update: 2011-11-14 06:35    [W:0.039 / U:0.060 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site