lkml.org 
[lkml]   [2011]   [Oct]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -next] usb gadget: fix langwell_udc.c build error
On 10/08/11 03:03, Felipe Balbi wrote:
> Hi,
>
> On Fri, Oct 07, 2011 at 01:57:42PM -0700, Randy Dunlap wrote:
>> From: Randy Dunlap <rdunlap@xenotime.net>
>>
>> Move function to fix langwell_udc.c build error:
>>
>> drivers/usb/gadget/langwell_udc.c: In function 'show_langwell_udc':
>> drivers/usb/gadget/langwell_udc.c:1693:3: error: implicit declaration of function 'lpm_device_speed'
>> drivers/usb/gadget/langwell_udc.c: At top level:
>> drivers/usb/gadget/langwell_udc.c:2637:37: error: conflicting types for 'lpm_device_speed'
>> drivers/usb/gadget/langwell_udc.c:1693:20: note: previous implicit declaration of 'lpm_device_speed' was here
>
> I don't have this compile error on my branch, did something go in
> without me noticing ?

probably not. What version of gcc are you using?
I'm using 4.5.1.

> Can you blame a comit which introduced this ?

I don't see such a commit.

> btw, all I have is a warning.

What warning?

--
~Randy
*** Remember to use Documentation/SubmitChecklist when testing your code ***


\
 
 \ /
  Last update: 2011-10-09 19:53    [from the cache]
©2003-2011 Jasper Spaans