[lkml]   [2011]   [Oct]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCHv5 2/4] usb: gadget: replace "is_dualspeed" with "max_speed"
    On Fri, Sep 09, 2011 at 04:14:21PM +0200, Michal Nazarewicz wrote:
    > On Fri, 26 Aug 2011 15:18:35 +0200, Michal Nazarewicz
    > <> wrote:
    > >This commit replaces usb_gadget's is_dualspeed field with
    > >a max_speed field.
    > >---
    > >
    > >I was unable to figure out how to create a symlink in
    > >non-race-condition way so for now I've created both speed and
    > >current_speed attributes. This needs to get fixed before getting
    > >merged.
    > >
    > >I would even consider just removing speed since udc-core got merged
    > >only in 3.1, so maybe it won't be such a big issue?
    > I've dug a bit deeper and could not find *any* way of creating the
    > speed -> current_speed symlink. sysfs_create_link() requires target
    > to be an kobject and as far as I can see attributes don't have one.
    > So I see the following possibilities:
    > 1. Leave speed only (as Felipe noticed, this may be confusing for
    > users since there will be "speed" and "maximum_speed").
    > 2. Rename it to current_speed without transition period (udc-core is
    > young so maybe no one will notice, but that won't be very nice).

    let's use current_speed without the grace period.

    [unhandled content-type:application/pgp-signature]
     \ /
      Last update: 2011-10-06 11:29    [W:0.020 / U:95.768 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site