[lkml]   [2011]   [Oct]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH] PM / Freezer: Freeze filesystems while freezing processes (v2)
    > PM / Freezer: Freeze filesystems while freezing processes (v2)
    > On Sunday, August 07, 2011, Dave Chinner wrote:
    >> On Sat, Aug 06, 2011 at 11:17:18PM +0200, Rafael J. Wysocki wrote:
    >>> From: Rafael J. Wysocki <>
    >>> Freeze all filesystems during the freezing of tasks by calling
    >>> freeze_bdev() for each of them and thaw them during the thawing of
    >>> tasks with the help of thaw_bdev().
    >>> This is needed by hibernation, because some filesystems (e.g. XFS)
    >>> deadlock with the preallocation of memory used by it if the memory
    >>> pressure caused by it is too heavy.
    > Below is an alternative fix, the changelog pretty much explains the
    > idea.
    > I've tested it on Toshiba Portege R500, but I don't have an XFS
    > partition to verify that it really helps, so I'd appreciate it if
    > someone able to reproduce the original issue could test it and report
    > back.

    Hi Rafael!

    Well, the kernel bugtracker is still down and I just like to post my
    experience with kernel (x64) v3.1-rc8/9 + patches. My machine is a
    MacBookPro, doomed with 4GB RAM running debian.

    Bug #1

    on the way to hibernate, machine hangs on

    "PM: Preallocating image memory..."

    this patch worked for me now for weeks:
    "[PATCH] PM / Freezer: Freeze filesystems while freezing processes (v2)"

    I was able to reproduce this bug with virtualbox and tested the patch ~40


    on resume from hibernate, hard reset (x64 only):

    With this patch I haven't got this issue again the last weeks.

    I wasn't able to reproduce this bug with virtualbox.

    I only got one pm-hibernate issue. Last line:

    Disabling non-boot CPUs ...

    This time I've enabled debug hung task :)


    Any other idea besides the possibility it's caused by evil earth
    radiation, isn't it?


    On 26.09.2011 00:10, Rafael J. Wysocki wrote:
    > On Sunday, September 25, 2011, Christoph wrote:
    >> On 25.09.2011 15:32, Rafael J. Wysocki wrote:
    >>> On Sunday, September 25, 2011, Christoph wrote:
    >>>> test results of the patch below:
    >>>> 1. real machine
    >>>> suspends fine but on wakeup, after loading image: hard reset. nvidia
    >>>> gpu => disabled compitz => wakeup worked two times.
    >>> Hmm, so there's a separate bug related to NVidia I guess.
    >> Maybe.
    >> Just made another test: the machine (macbook) woke up, loaded image, thaw.
    >> It got stuck at vt#1, displaying console with login. Cursor blinking, but
    >> no (usb) keyboard or network enabled. Bricked?!!
    >> On the other hand I've got another box with nvidia gpu:
    >> debian5 32bit
    >> #3 SMP Fri Apr 1
    >> nvidia 260.19.36
    >> It's up since I compiled the kernel: I use it twice a week and I kept it
    >> freezed all the time. It was solid rock until today: hard reset on resume.
    >> WTF? (I remember this version combo was stable on the macbook but the
    >> kernel lacks a solid wireless driver).
    > If that's an x86_64 system, there is a known bug causing problems like
    > this to happen. There's a patch fixing it, but not conclusive:
    > Thanks,
    > Rafael
    > _______________________________________________
    > xfs mailing list

     \ /
      Last update: 2011-10-22 17:17    [W:0.026 / U:0.112 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site