lkml.org 
[lkml]   [2011]   [Oct]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] params: make dashes and underscores in parameter names truly equal
On 10/13/2011 01:28 AM, Rusty Russell wrote:
> Idea is solid, implementation has a few quirks. As the name
> obsolete_checksetup() implies, this was only supposed to be a crutch for
> old __setup() calls. Modern code should be using module_param() or
> core_param().

... instead of __setup()?
No objection to the change in do_early_param() ?

> Did you have a specific example?

The specific example I had in mind was the one from
Documentation/kernel-parameters.txt:

log_buf_len=1M print-fatal-signals=1
can also be entered as
log-buf-len=1M print_fatal_signals=1

'log-buf-len=1M' does not work because it's an early_param().
'print_fatal_signals=1' does not work because it's defined as
__setup("print-fatal-signals=", ...);

> Perhaps we should work on converting
> them all, which would have beneficial side-effects as we poke into old
> code...

Let's see how many __setup() parameters there are:
$ git grep -E '^__setup\("' |wc -l
457

Only the ones with a dash or underscore in the name:
$ git grep -E '__setup\(".*[_-].*"' | wc -l
180

It will take some time.

Thanks,
Michal


\
 
 \ /
  Last update: 2011-10-13 16:43    [W:0.074 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site