lkml.org 
[lkml]   [2011]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] params: make dashes and underscores in parameter names truly equal
Date
On Mon, 10 Oct 2011 00:03:37 +0200, Michal Schmidt <mschmidt@redhat.com> wrote:
> The user may use "foo-bar" for a kernel parameter defined as "foo_bar".
> Make sure it works the other way around too.

Hi Michal,

Idea is solid, implementation has a few quirks. As the name
obsolete_checksetup() implies, this was only supposed to be a crutch for
old __setup() calls. Modern code should be using module_param() or
core_param().

Did you have a specific example? Perhaps we should work on converting
them all, which would have beneficial side-effects as we poke into old
code...

Thanks!
Rusty.


\
 
 \ /
  Last update: 2011-10-13 02:53    [from the cache]
©2003-2011 Jasper Spaans