lkml.org 
[lkml]   [2011]   [Oct]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCHv9 03/18] TEMP: OMAP3xxx: hwmod data: add PRM hwmod
On Tue, 11 Oct 2011, Cousson, Benoit wrote:

> On 10/10/2011 10:42 PM, Paul Walmsley wrote:
>
> > If it's the "3xxx" that you're objecting to in the name, we could call it
> > "prm2" or "prmxyz" - the '3xxx' just seemed like the most logical
> > approach. The name of the hwmod class in the patch is still "prm", of
> > course.
>
> Yes, but that's different, the number is supposed to represent the instance
> number in the IP naming convention. So prm2 != prmv2.

Heh, that works as long as there's no "prmv" IP block ;-)

> > Thoughts?
>
> In fact the device name does not have to match the hwmod name. So we can just
> create an "omap2_prm" omap_device for OMAP2, "omap3_prm" omap_device for
> OMAP3...
> That will allow the relevant PRM driver to be bound to the proper device.

We can, we'd just need to add this extra mapping layer, so it doesn't
become a nasty special-case hack for each IP block that this applies to.

Sounds like something for 3.3 (if ever...)


- Paul


\
 
 \ /
  Last update: 2011-10-11 00:37    [from the cache]
©2003-2011 Jasper Spaans