lkml.org 
[lkml]   [2011]   [Jan]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
SubjectRe: has the i915 "black screen" boot issue returned? [BISECTED]
From
On Fri, 28 Jan 2011 09:51:01 -0500 (EST), "Robert P. J. Day" <rpjday@crashcourse.ca> wrote:
> sadly, no change -- still black screen. again, rebooted
> successfully under commit 8a327f23. just to be clear, here's "git
> diff":
>
> $ git diff
> diff --git a/include/linux/acpi_io.h b/include/linux/acpi_io.h
> index 7180013..e035f3c 100644
> --- a/include/linux/acpi_io.h
> +++ b/include/linux/acpi_io.h
> @@ -7,7 +7,7 @@
> static inline void __iomem *acpi_os_ioremap(acpi_physical_address phys,
> acpi_size size)
> {
> - return ioremap_cache(phys, size);
> + return ioremap(phys, size);
> }

Ok, that implies the new mapping is fine and not the cause of the issue.

Instead you have some OpRegion related regression hidden until till now
because the conflicting mapping disabled it for i915.

That would be easy to test by returning early in intel_opregion_setup():

diff --git a/drivers/gpu/drm/i915/intel_opregion.c
b/drivers/gpu/drm/i915/intel_
index 9efccb9..8c93201 100644
--- a/drivers/gpu/drm/i915/intel_opregion.c
+++ b/drivers/gpu/drm/i915/intel_opregion.c
@@ -470,6 +470,8 @@ int intel_opregion_setup(struct drm_device *dev)
u32 asls, mboxes;
int err = 0;

+ return -ENOTSUPP;
+

pci_read_config_dword(dev->pdev, PCI_ASLS, &asls);
DRM_DEBUG_DRIVER("graphic opregion physical addr: 0x%x\n", asls);
if (asls == 0) {
--
Chris Wilson, Intel Open Source Technology Centre


\
 
 \ /
  Last update: 2011-01-28 16:07    [W:0.040 / U:6.536 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site