lkml.org 
[lkml]   [2011]   [Jan]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.36/2.6.37: broken compatibility with userspace input-utils ?
On Wed, Jan 26, 2011 at 02:33:17PM -0500, Mark Lord wrote:
> On 11-01-26 12:32 PM, Mauro Carvalho Chehab wrote:
> > Em 26-01-2011 13:05, Mark Lord escreveu:
> ..
> >> Nope. Does not work here:
> >>
> >> $ lsinput
> >> protocol version mismatch (expected 65536, got 65537)
> >
> > You need to relax the version test at the tree. As I said before, this is
> > a development tool from the early RC days, bound to work with one specific
> > version of the API, and programmed by purpose to fail if there would by any
> > updates at the Input layer.
> ..
>
> As I said before, I personally have done that on my copy here.
> But that's not what this thread is about.
>
> This thread is about broken userspace courtesy of these changes.
> So I am testing with the original userspace binary here,
> and it still fails. And will continue to fail until that regression is fixed.

I do not consider lsinput refusing to work a regression. The tool
claims to work with particular protocol version and it is tool's choice.

Shall I write a utility that checks kernel version and only works with
2.6.37 and yell when we release 2.6.38?

--
Dmitry


\
 
 \ /
  Last update: 2011-01-26 20:43    [from the cache]
©2003-2011 Jasper Spaans