lkml.org 
[lkml]   [2011]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: 2.6.36/2.6.37: broken compatibility with userspace input-utils ?
On Wed, Jan 26, 2011 at 8:00 AM, Mauro Carvalho Chehab
<mchehab@redhat.com> wrote:
>
> See, it will only look into the 16-bits scancode space. There are several remote
> controllers with 24 bits and 32 bits, so the tool is already broken anyway.

Mauro, stop blathering.

The problem is that the tool used to work with OLD DEVICES AND SETUPS
that used to work. That broke. It needs to get fixed.

We do not change user-land ABI. Not now, not ever. And no, "the tool
is broken" is NOT an excuse. Bringing it up as one is unacceptable.
The fact that there are devices that didn't use to be supported at all
that don't work with the old tool has absolutely ZERO relevance,
because that's not a regression.

No regressions. No excuses. No "user-land is broken", however much you
disagree with it.

Linus


\
 
 \ /
  Last update: 2011-01-25 23:29    [from the cache]
©2003-2011 Jasper Spaans