lkml.org 
[lkml]   [2010]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] USB: otg: twl4030: fix phy initialization(v1)
From
Hi Ming Lei &  Balbi,

Thanks for your support and the porblem is resolved.

Venkii,
On Tue, Sep 7, 2010 at 11:52 PM, venki kaps <venkiece2005@gmail.com> wrote:
> Venkii,
> On Tue, Sep 7, 2010 at 11:45 PM, venki kaps <venkiece2005@gmail.com> wrote:
>> Venkii,
>> On Tue, Sep 7, 2010 at 9:18 PM, venki kaps <venkiece2005@gmail.com> wrote:
>>> Venkii,
>>>
>>> On Tue, Sep 7, 2010 at 9:10 PM, Ming Lei <tom.leiming@gmail.com> wrote:
>>>> 2010/9/7 venki kaps <venkiece2005@gmail.com>:
>>>>> thanks for your good response.
>>>>>
>>>>> Venkii,
>>>>>
>>>>> On Tue, Sep 7, 2010 at 6:54 PM, Ming Lei <tom.leiming@gmail.com> wrote:
>>>>>> 2010/9/7 venki kaps <venkiece2005@gmail.com>:
>>>>>>> Dear USB experts,
>>>>>>>
>>>>>>>  Is the same fix valid for omap3430 + 2.6.32 Kernel?
>>>>>>>
>>>>>>>  I have been facing mp3 playback idle current consumption 20mA more
>>>>>>> after booting without USB cable connected
>>>>>>>  but If USB cable detach and attach happen, then able to hit proper
>>>>>>> values otherwise irrespective of cold/warm reset
>>>>>>>  the current values increases to 20mA.
>>>>>>>
>>>>>>>  with cable,
>>>>>>>      OTG_SYSCONFIG standby mode of operation - SMART idle
>>>>>>>      HSOTGUSB_STANDBY - SMART standby
>>>>>>>
>>>>>>>  without cable,
>>>>>>>        OTG_SYSCONFIG standby mode of operation - SMART idle
>>>>>>>        HSOTGUSB_STANDBY - Active
>>>>>>>
>>>>>>>  Even i have applied  patch but still the same issue.
>>>>>>
>>>>>> Are you applying the patch below?
>>>>>>
>>>>>>         http://marc.info/?l=linux-omap&m=128378686221264&w=2
>>>>>>
>>>>>> The patch(USB: otg: twl4030: fix phy initialization(v1)) above is against
>>>>>> 2.6.36-rc3, I don't think you can apply it directly on 2.6.32. And the patch
>>>>>> is introduced to fix the problems caused by
>>>>>>
>>>>>>          commit 461c317705eca5cac09a360f488715927fd0a927.
>>>>>>
>>>>>> which change is committed into mainline 2.6.36-rc3.
>>>>>  >>> Yes, this patch i have applied.
>>>>
>>>> If you applied the patch, I guess you may see __twl4030_phy_power(twl, 0)
>>>> is called from .probe.
>>>>
>>>> If called,  seems your description a little contradictory since you observed
>>>> __twl4030_phy_power(twl, 0) may hit proper values, right?
>>>
>>>  Yes, __twl4030_phy_power(twl, 0) -  the current values are getting
>>> proper with or without cable.
>>>>
>>>> If not called, could you trace the return value of twl4030_usb_linkstat in
>>>> twl4030_usb_phy_init?
>>> ok, i can do that and update.
>>     twl4030_usb_linkstat return value is zero (0) in both
>> twl4030_usb_phy_init/twl4030_usb_irq.
>  WIth twl4030_usb_phy_init, Everything is fine except battery temperature
>  but surprisingly the temperature is fine with PC based usb cable charger and
>  the problem is with travel adapter only.

The temperature with TA effected due to the TWL4030 PHY power down on
I2c(__twl4030_phy_power(twl, 0)).
When TA connect to the phone the battery ADC is not reading proper
values since already PHY power down.

To resolve the above issue, we have made "PHY power on" in battery
adc on function
and "PHY power down" in battery adc off function.

With the above change the problem is resolved.

>>>> thanks,
>>>>
>>>> --
>>>> Lei Ming
>>>>
>>>
>>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2010-09-08 17:57    [W:0.058 / U:6.004 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site